Page 1 of 1

Need help upgrading firmware

Posted: 17 Jan 2019, 19:16
by arflyer
Hi, I'm trying to update the firmware on my AR.Drone using the USB method described at https://coverclock.blogspot.com/2011/04 ... art-6.html

Things seem to go well but when I run usb_flash to flash the firmware, I get errors.

What happens is perhaps best described by this image:
2019-01-16.parrot_ar_drone_firmware_update_fail.jpg
As you can see, in the "FIRMWARE INSTALLATION" step, after the "Closing usb connection" message, my laptop can't reconnect to the drone. Which is weird, as the "INSTALLER INSTALLATION" step could reconnect successfully.

Does anyone have any suggestions on how to fix this? I'm attaching two more images, the first one is the Device Manager before running usb_flash:
2019-01-16.parrot_ar_drone_device_manager_1.jpg
And the second image is of the Device Manager after running usb_flash:
2019-01-16.parrot_ar_drone_device_manager_2.jpg
Is there any special Windows driver I need to install to get things working?

(The reason I'm trying this way is that neither my phone nor my tablet manages to connect to the drone, even though the Ardrone_0xxxxx network can be seen by them. I have tried unpairing, resetting, holding down Unpair to switch network mode etc., but nothing helps, so I'm hoping a firmware re-flash will fix things.)

Re: Need help upgrading firmware

Posted: 20 Jan 2019, 15:42
by ar202018
Did you try reset with the battery connected? I only ask because I had same issue and did not realize reset only works with battery connected.

Re: Need help upgrading firmware

Posted: 24 Jan 2019, 16:52
by arflyer
Yes, the battery was connected when I reset the drone.