Login to disable ads!

AR Drone 2.0 does not create wifi hotspot

Problems of AR Drone 2.0, Freeflight 2, Flight Recorder GPS, Qgroundcontrol... etc.
Post Reply
frogeyedman
Newcomer
Posts: 3
Joined: 05 Jul 2019, 21:05
Drone Type: AR.Drone 2
Has thanked: 0
Been thanked: 0

AR Drone 2.0 does not create wifi hotspot

Post by frogeyedman » 05 Jul 2019, 21:07

Hi guys,
So I have an ardrone 2.0, it does not create a wifi hotspot, tried it with multiple devices, tried to reset it many times. It just wont create a wifi network, so I created an serial connection with the drone.

When I cd into the /bin/ dir I run the board_check, this returns:

Code: Select all

---- BOARD CHECK ---- wmiconfig: ath0: No such device ping: sendto: Network is unreachable Wifi [ERROR] UART motor [ERROR] UART PIC [ERROR]
However on boot it says this:

Code: Select all

<starting info>Version="AR.Drone 2.4.8" WIFI="OK" AddrMAC="00:00:00:00:00:00" Calibration="OK" PICVersion="5.34" Motor1Version="1.43" Motor2Version="1.43" Motor3Version="1.43" Motor4Version="1.43"</starting info>
The wifi is “OK” but there is no mac address, does anyone know how this is possible and if its fixable ?

Thanks in advance.

User avatar
AR.Tommy
Serious flight time
Posts: 1317
Joined: 07 Oct 2010, 07:59
Drone Type: Bebop
Has thanked: 67 times
Been thanked: 57 times

Re: AR Drone 2.0 does not create wifi hotspot

Post by AR.Tommy » 06 Jul 2019, 07:51

I think the problem is elsewhere because I'm pretty sure this refers to the "owner mac address".

Pairing on the AR.Drone works by saving the owners mac address, then rejecting every other packets through a firewall rule. An owner address of 00:00:00:00:00:00 means this AR.Drone is not paired.

What does ifconfig say?
http://www.digitalsirup.com

Sweet and delicious apps for your drones.

frogeyedman
Newcomer
Posts: 3
Joined: 05 Jul 2019, 21:05
Drone Type: AR.Drone 2
Has thanked: 0
Been thanked: 0

Re: AR Drone 2.0 does not create wifi hotspot

Post by frogeyedman » 08 Jul 2019, 18:02

That make's sense,

Code: Select all

ifconfig
returns this:

Code: Select all

# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
I forgot to mention what the wifi_setup.sh returns in the original post, bit of a bigger log but what i get from it is that the wifi card can't be found:

Code: Select all

# cd /bin/
# wifi_setup.sh
Platform set to parrot-omap-sdio
Platform Setup Script is: /lib/firmware/host/support/platformscripts/plat_parrot-omap-sdio.sh
Image path: /lib/firmware/host/.output/parrot-omap-sdio/image
Mac address: 90:03:B7:FE:42:BF
insmod: can't insert '/lib/firmware/host/.output/parrot-omap-sdio/image/ar6000.ko': File exists
Platform script failed : loadAR6K
/usr/sbin/loadAR6000.sh: exit: line 326: Illegal number: -1
Lets sleep for 4 seconds..
Unknown HZ value! (92) Assume 100.
Unknown HZ value! (92) Assume 100.
chrt: can't get pid 25's policy: No such process
pid 642's current scheduling policy: SCHED_OTHER
pid 642's current scheduling priority: 0
pid 642's new scheduling policy: SCHED_RR
pid 642's new scheduling priority: 24
wmiconfig: ath0: No such device
wmiconfig: ath0: No such device
wmiconfig: ath0: No such device
SSID=ardrone2_122604
Creating master Network ardrone2_122604
Error for wireless request "Set Mode" (8B06) :
    SET failed on device ath0 ; No such device.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device ath0 ; No such device.
wmiconfig: ath0: No such device
Error for wireless request "Set Frequency" (8B04) :
    SET failed on device ath0 ; No such device.
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device ath0 ; No such device.
Error for wireless request "Commit changes" (8B00) :
    SET failed on device ath0 ; No such device.
wmiconfig: ath0: No such device
wmiconfig: ath0: No such device
ifconfig: SIOCSIFADDR: No such device
arping: interface eth0 not found: No such device
Using address 192.168.1.1
Owner's MAC address is:  00:00:00:00:00:00
Clearing pairing rule
route: SIOCADDRT: No such device
net.netfilter.nf_conntrack_tcp_timeout_syn_sent = 12
net.netfilter.nf_conntrack_tcp_timeout_syn_recv = 6
net.netfilter.nf_conntrack_tcp_timeout_fin_wait = 12
net.netfilter.nf_conntrack_tcp_timeout_close_wait = 6
net.netfilter.nf_conntrack_tcp_timeout_last_ack = 10
net.netfilter.nf_conntrack_tcp_timeout_time_wait = 12
net.netfilter.nf_conntrack_tcp_timeout_close = 10
Parrot Auth Server is running.
The weird thing is, I can't find anyone that has a similar issue.

User avatar
AR.Tommy
Serious flight time
Posts: 1317
Joined: 07 Oct 2010, 07:59
Drone Type: Bebop
Has thanked: 67 times
Been thanked: 57 times

Re: AR Drone 2.0 does not create wifi hotspot

Post by AR.Tommy » 08 Jul 2019, 18:48

Very likely something is broken (I mean hardware) - any hard crashes lately?
http://www.digitalsirup.com

Sweet and delicious apps for your drones.

frogeyedman
Newcomer
Posts: 3
Joined: 05 Jul 2019, 21:05
Drone Type: AR.Drone 2
Has thanked: 0
Been thanked: 0

Re: AR Drone 2.0 does not create wifi hotspot

Post by frogeyedman » 08 Jul 2019, 19:57

There was a crash, but not a hard one. I wanted to fly a few weeks back, took of and after 10 seconds it fell to the ground, it was indoors so about 50cm high, not hard at all.

I'm thinking about using a heatgun for the motherboard, this helped with my xbox360 back in the day when the hardware was broken :|

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests