Login to disable ads!

My bebop battery won't charge

Questions and answers about Bebop, Bebop 2 and the Parrot Skycontroller.
Post Reply
DeCoder21
Newcomer
Posts: 1
Joined: 03 Jan 2019, 20:36
Drone Type: Bebop
Has thanked: 0
Been thanked: 0

My bebop battery won't charge

Post by DeCoder21 » 03 Jan 2019, 20:41

After 3 months of not using my bebop,
I took it and tried to charge the battery, it charged it great and then I used it and it was emptyed to 50%
I tried to charge it again and it showed me the normanl red led, I charged it for an hour and a half and it was not green.
I connected it to the drone and it was still at 50% :(.
I trided to charge it a few times and still the same :(.
what should I do?

Thanks for reading :)

oscar30340
Ready for take off
Posts: 13
Joined: 18 Jan 2019, 12:37
Drone Type: Bebop 2
Location: South of France
Has thanked: 2 times
Been thanked: 0

Re: My bebop battery won't charge

Post by oscar30340 » 18 Jan 2019, 15:15

Hello,
Sorry for my bad English. :oops:

Each battery cell should be measured to see if it is too low, or connect the battery to a balancing charger. (but you have to make a cable)

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests