Random landing's with MacGyver Mod - The solution

Mirumod, Macgyver, hull, cam, propeller, leg, cross, ball bearing mods... etc.
User avatar
tonyh0905
Chased the cat
Posts: 336
Joined: 28 Jan 2012, 11:25
Location: Wales

Re: Random landing's with MacGyver Mod

Post by tonyh0905 » 12 Mar 2012, 22:37

spudmonkeybikes wrote:
Do you have the failsafe receiver, only asking as I've had similar incidents but I'm waiting for the failsafe receiver to turn up and then I'm going to do some tests. I think the noise you are hearing is when the drone is just compensating using the gyros for the wind as the noise is linked to it titling backwards and forwards from the video. Not flown for a few weeks as waiting for the rx to land and also my f450.
Hi Spud
I am assuming that mine is the failsafe RX, because when I turn the transmitter off with the drone in flight it will land. I may have mentioned this before, but when I tested this, by just flicking the TX power of and back on very quickly the drone landed, but the RX had a flashing red led to tell me there had been a loss of communication.

I flew the drone today in a field where I have experienced a lot of these problems, using wifi and my android phone. I had no problem s at all, so I guess the fault must be with the TX or RX.
ArDrone V1 / MiruMod
808 # 16 camera

DJI F450 / Dx6i
GoPro Hero3 silver

http://www.youtube.com/user/tonyh0905

spudmonkeybikes
Strange wobble
Posts: 213
Joined: 15 Jan 2012, 23:11

Re: Random landing's with MacGyver Mod

Post by spudmonkeybikes » 12 Mar 2012, 22:59

I'm not sure, I think the failsafe is in the board attached to the receiver and not actually the receiver as the flysky doesn't have a failsafe rx but you can get a failsafe rx combination, if that makes sense. Where as your rx will maybe have its own failsafe in the actual rx unti.

lesodell
Chased the cat
Posts: 452
Joined: 22 Feb 2011, 21:30
Location: michigan

Re: Random landing's with MacGyver Mod

Post by lesodell » 13 Mar 2012, 23:31

from the horse mouth


The reasons for an 'auto' land from the mod's side are:
a) flight mode LAND gets activated, could be a loose wire, bad solderjoint
b) RX signals corrupted, again, loose wire, bad contact on one of the channels, use SETUP mode and wiggle all the wires.
c) RX looses contact to TX, unlikely if you are close, but it does happen...
d) VLBA kicks in, you would see the drones motorlights blinking red while it lands, they may go back to green once the motors shut off and the battery recovers.
Observe what happens when it 'auto' lands and try to launch it again, what do you have to do to get it back up?

spudmonkeybikes
Strange wobble
Posts: 213
Joined: 15 Jan 2012, 23:11

Re: Random landing's with MacGyver Mod

Post by spudmonkeybikes » 14 Mar 2012, 05:53

lesodell wrote:from the horse mouth


The reasons for an 'auto' land from the mod's side are:
a) flight mode LAND gets activated, could be a loose wire, bad solderjoint
b) RX signals corrupted, again, loose wire, bad contact on one of the channels, use SETUP mode and wiggle all the wires.
c) RX looses contact to TX, unlikely if you are close, but it does happen...
d) VLBA kicks in, you would see the drones motorlights blinking red while it lands, they may go back to green once the motors shut off and the battery recovers.
Observe what happens when it 'auto' lands and try to launch it again, what do you have to do to get it back up?
Thanks will try these, is item 2 for the transmitter connected to a pc? Not even downloaded the software but will do later as a check.

lesodell
Chased the cat
Posts: 452
Joined: 22 Feb 2011, 21:30
Location: michigan

Re: Random landing's with MacGyver Mod

Post by lesodell » 14 Mar 2012, 13:58

i think it is the rx link to the drone

spudmonkeybikes
Strange wobble
Posts: 213
Joined: 15 Jan 2012, 23:11

Re: Random landing's with MacGyver Mod

Post by spudmonkeybikes » 14 Mar 2012, 20:53

My failsafe rx turned up today so when I get a chance I'll have a play and post the results.

User avatar
tonyh0905
Chased the cat
Posts: 336
Joined: 28 Jan 2012, 11:25
Location: Wales

Re: Random landing's with MacGyver Mod

Post by tonyh0905 » 15 Mar 2012, 00:09

lesodell wrote:from the horse mouth


The reasons for an 'auto' land from the mod's side are:
a) flight mode LAND gets activated, could be a loose wire, bad solderjoint
b) RX signals corrupted, again, loose wire, bad contact on one of the channels, use SETUP mode and wiggle all the wires.
c) RX looses contact to TX, unlikely if you are close, but it does happen...
d) VLBA kicks in, you would see the drones motorlights blinking red while it lands, they may go back to green once the motors shut off and the battery recovers.
Observe what happens when it 'auto' lands and try to launch it again, what do you have to do to get it back up?
Thanks lesodell and the horse ;)

In light of point a) & b) I split the Arduino board and RX to check all the soldered joints. They were all perfect, and the wires were all sound. I must admit the workmanship on the MacGyver mod is very good.
c) RX is giving me some concerns, as it comes up well short of the 90ft range check, closer to 40ft. I still do not see a warning light on the RX after a random land to say there was a loss of contact.
d)I don't think VLBA can be a cause because these incidents tend to happen when I'm flying high, and I will only do that at the start of a flight , and for the first few minutes. After the last one I just reset the emergency (the drone ended up on its back), and the gyro's and took off again. I flew for another 6 or 7 minutes (keeping it low) before the VLBA kicked in.

Are you supposed to be able to fly with the RC mod and still be able to view the video downlink through freeflight? If I try to do this the drone will auto land every time, within 1 to 30 seconds of take off.
ArDrone V1 / MiruMod
808 # 16 camera

DJI F450 / Dx6i
GoPro Hero3 silver

http://www.youtube.com/user/tonyh0905

spudmonkeybikes
Strange wobble
Posts: 213
Joined: 15 Jan 2012, 23:11

Re: Random landing's with MacGyver Mod

Post by spudmonkeybikes » 15 Mar 2012, 06:02

Tony, I don't use any app at all when flying because I'm sure the apps effect the rc mod and I take an old android phone to check the frequency isn't full.

lesodell
Chased the cat
Posts: 452
Joined: 22 Feb 2011, 21:30
Location: michigan

Re: Random landing's with MacGyver Mod

Post by lesodell » 15 Mar 2012, 23:06

i can fly with the mod on and freeflight going .

knoxploration
Chased the cat
Posts: 439
Joined: 26 Dec 2011, 23:08
Drone Type: AR.Drone
Location: Knoxville, Tennessee

Re: Random landing's with MacGyver Mod

Post by knoxploration » 15 Mar 2012, 23:40

Interestingly, I hit this same problem myself for the first time today, in the same place I do almost all of my flying. No radio antennas nearby, and it's low-density residential so only a handful of WiFi networks, none new.

It seemed mostly to happen over long grass or near the transition altitude; I wonder if the ultrasonic sensor and mod could be getting confused about the drone's height and hence triggering a landing?

lesodell
Chased the cat
Posts: 452
Joined: 22 Feb 2011, 21:30
Location: michigan

Re: Random landing's with MacGyver Mod

Post by lesodell » 16 Mar 2012, 14:01

Mine did it for the first time last week to ,i womder what is going on ?

JG-rn
Chased the cat
Posts: 346
Joined: 08 Jan 2012, 20:39
Location: NJ

Re: Random landing's with MacGyver Mod

Post by JG-rn » 16 Mar 2012, 15:15

Same problem last flight

User avatar
tonyh0905
Chased the cat
Posts: 336
Joined: 28 Jan 2012, 11:25
Location: Wales

Re: Random landing's with MacGyver Mod

Post by tonyh0905 » 16 Mar 2012, 17:48

What firmware are we all using gents? I'm on firmware 1.7.11.

Is it worth trying to downgrade to 1.7.6?
ArDrone V1 / MiruMod
808 # 16 camera

DJI F450 / Dx6i
GoPro Hero3 silver

http://www.youtube.com/user/tonyh0905

lesodell
Chased the cat
Posts: 452
Joined: 22 Feb 2011, 21:30
Location: michigan

Re: Random landing's with MacGyver Mod

Post by lesodell » 17 Mar 2012, 15:02

1.7.11 here to but is has been flying it ok ,i will have to try the down grade and see if that helps :(

JG-rn
Chased the cat
Posts: 346
Joined: 08 Jan 2012, 20:39
Location: NJ

Re: Random landing's with MacGyver Mod

Post by JG-rn » 17 Mar 2012, 17:49

Happened again today. Now my drone is gone...

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests