Login to disable ads!

Can’t take off

Mirumod, Macgyver, hull, cam, propeller, leg, cross, ball bearing mods... etc.
Post Reply
amuawad1
Newcomer
Posts: 1
Joined: 08 Sep 2019, 15:57
Drone Type: AR.Drone 2
Has thanked: 0
Been thanked: 0

Can’t take off

Post by amuawad1 » 08 Sep 2019, 16:06

Can I point out I’m a complete novice with drones. A year ago I got a parrot airdrome 2.0 which worked fine at the beginning but then I left it for about a year as family problems arose. Today I tried flying it and it just skated around the floor. Wouldn’t take off. Am very keen to get this working as can’t afford a new one.

Thrasherg
Ready for take off
Posts: 18
Joined: 29 May 2019, 04:42
Drone Type: Bebop 2
Location: Dallas, TX
Has thanked: 0
Been thanked: 0

Re: Can’t take off

Post by Thrasherg » 09 Sep 2019, 17:39

This is puzzling, usually if a drone can't take off, it's either the propellers are on wrong or the battery has insufficient power. It hard to put a Bebop propeller on wrong (hard but not impossible :) ) and if the battery has insufficient power the bebop usually reports this and will not try to take off!! Yours is trying but not getting in the air. As you left it for a year I suspect the battery is at fault but it's only a guess. Do you have another battery you can try. The batteries must NOT be stored fully charge and DO need to be checked every few weeks, I suspect you just put yours away fully charged and have come back a year later and are trying to fly it. So it's probably the battery however the drone should sense the battery charge level and not try to fly if it's too low but batteries do do strange things!!

Maybe others will have ideas!!

Gary
Parrot Bebop 2’s, Airborne Night, Mambo FPV, and a few cheap drones!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest