DD WRT help please

Router, repeater (extender), GPS unit, antenna, tablet, FPV goggle, HD battery, charger, carrying case... etc.
Post Reply
Oztravels
Ready for take off
Posts: 16
Joined: 23 Sep 2012, 07:35
Drone Type: AR.Drone 2

DD WRT help please

Post by Oztravels » 29 Sep 2012, 07:47

Hi Folks. I have been trying (unsuccessfully) to use my modified (DD-WRT) Linksys router as a repeater for my ar drone 2.0. Most of the instructions deal with linking (bridging?) two routers (http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge" onclick="window.open(this.href);return false;) however I seem to recall reading that I can just use the one router for the job. Can anyone point me in the right direction for instructions. I seem to get lost when linking the drone (which I can see on the scan) and the iPad. Thanks in advance

David

User avatar
costing
Ready for take off
Posts: 42
Joined: 29 Sep 2012, 23:30
Drone Type: AR.Drone 2
Location: France

Re: DD WRT help please

Post by costing » 30 Sep 2012, 00:05

See that the pairing option is *off*, if it works like this you can enable it back like this. The other router the documentation refers to is the drone itself. Make sure the router has a different IP than the drone (eg 192.168.1.100) and a different ssid.

Oztravels
Ready for take off
Posts: 16
Joined: 23 Sep 2012, 07:35
Drone Type: AR.Drone 2

Re: DD WRT help please

Post by Oztravels » 30 Sep 2012, 09:15

Thanks costing. Yes I had read that the drone becomes the second router but the configuration instruction escapes me as to how it applies to the drone. Maybe i am out of my depth. ;)

User avatar
costing
Ready for take off
Posts: 42
Joined: 29 Sep 2012, 23:30
Drone Type: AR.Drone 2
Location: France

Re: DD WRT help please

Post by costing » 30 Sep 2012, 16:32

You can start with the untouched drone, just turn its pairing option off and leave the battery plugged in, it has to be online for DHCP purposes.

On the router:
Setup -> Basic Setup
  • Wireless setup
    • STP : Disable
  • Network setup -> Router IP
    • Local IP Address : 192.168.1.100
    • Subnet Mask : 255.255.255.0
    • Gateway : 0.0.0.0
    • Local DNS : 0.0.0.0
  • Assign WAN Port to Switch : disabled
Wireless -> Basic settings
  • Wireless Physical Interface wl0
    • Wireless Mode : Repeater Bridge
    • Wireless Network Name (SSID) : <the exact SSID of your drone>
    • Network Configuration : Bridged
  • <add a virtual interface from the Add button below the Physical interface settings then>
  • Virtual Interfaces wl0.1 SSID
    • Wireless Network Name (SSID) : <a unique name in your environment, I used the name of the drone network + something>
    • Wireless SSID Broadcast : Enable
    • AP Isolation : Disable
    • Network Configuration : Bridged
Wireless -> Wireless security
  • Security Mode : Disabled on both wireless interfaces (physical and virtual)
Wireless -> Advanced settings
  • TX Power : the max allowed value, in my case it was default 71, max was 251, it should make a difference in range ...
  • Bluetooth Coexistence Mode : enable it if you will use something like the PS3 controller over bluetooth
Wireless -> MAC filter (optional but recommended, do this when everything else works)
  • Use Filter : Enable
  • Filter Mode : Permit only clients listed to access the wireless network
  • Edit MAC filter list : add here all MAC addresses of your devices (tablets, phones, laptops, whatever you use to access the router and/or the drone, you might need any of them later on ...)
This is just the official tutorial applied to the drone particular case, so please cross-check with the official instructions. Make sure you start from a clean configuration.

If it still doesn't work you can try to connect with a laptop to the router, with a fixed IP address like 192.168.1.3. Then open http://192.168.1.110 and see if that under Wireless -> Access point & Clients you see at least two MAC addresses:

Code: Select all

MAC Address	    Interface
<mac of drone >	eth1
<mac of laptop>	wl0.1
Then try to connect to the drone (ping 192.168.1.1 / telnet 192.168.1.1). If you get so far everything should be set up properly.

Good luck!

Oztravels
Ready for take off
Posts: 16
Joined: 23 Sep 2012, 07:35
Drone Type: AR.Drone 2

Re: DD WRT help please

Post by Oztravels » 01 Oct 2012, 08:05

Brilliant!!!! Worked perfectly, thank you soooo much! I can now see why people use a secondary router as the primary cant be an access point AND a repeater bridge at the same time.

I assume the wifi signal I see on my ipad (free flight) is actually the signal between my router and the iPad and doesn't reflect the signal between the drone and the iPad?

Anyway thanks again...If you are ever passing the Philippines I owe you a beer.

Ciao

D

User avatar
MaxFlyer
Made it over nextdoor
Posts: 261
Joined: 31 May 2012, 21:23
Drone Type: AR.Drone 2

Re: DD WRT help please

Post by MaxFlyer » 01 Oct 2012, 13:31

Oztravels wrote:I assume the wifi signal I see on my ipad (free flight) is actually the signal between my router and the iPad and doesn't reflect the signal between the drone and the iPad?
That's correct, so take care not to become delirious (and let your drone fly-away) seeing the "full bars" on your iPad!

;)

There's a new feature in ARDrone Flight for Android that purportedly provides the sig level for the Drone itself, but afaik no such thing is available for iOS devices.

User avatar
costing
Ready for take off
Posts: 42
Joined: 29 Sep 2012, 23:30
Drone Type: AR.Drone 2
Location: France

Re: DD WRT help please

Post by costing » 01 Oct 2012, 14:57

@Oztravels You can see the signal strength on the entry page of your DD-WRT, on the bottom of the page where the MAC addresses of connected devices are displayed. I don't know how the app will behave if put in background though ... I'll try on Android myself next time. So far I didn't manage to get out of its range so I was not curious to see how good the signal is, but now I am :)

Philippines is fantastic! Looking forward for the next occasion to visit ...

FOERUMZ
Newcomer
Posts: 2
Joined: 02 Oct 2012, 20:46
Drone Type: AR.Drone 2

Re: DD WRT help please

Post by FOERUMZ » 02 Oct 2012, 20:49

First off, let me say that this post was inspirational. Secondly, this forum has already helped me with two problems, ultrasound emergency and lack of range. Pure awesome. THANKS! Oh and also, I can confirm that the signal meter is corresponding to the drone on android OS.

mike1682
Newcomer
Posts: 1
Joined: 17 Nov 2015, 21:10
Drone Type: AR.Drone

Re: DD WRT help please

Post by mike1682 » 18 Nov 2015, 19:38

Hi Costing! I know this is an old thread but i have been looking forever for a way to control my brookstone rover tank remotely. The tank generates its own wifi. I want to beable to control the tank from my office. Is there anyway to to this! Similar to what your talking about to hear!! thx so much if you get this



costing wrote:You can start with the untouched drone, just turn its pairing option off and leave the battery plugged in, it has to be online for DHCP purposes.

On the router:
Setup -> Basic Setup
  • Wireless setup
    • STP : Disable
  • Network setup -> Router IP
    • Local IP Address : 192.168.1.100
    • Subnet Mask : 255.255.255.0
    • Gateway : 0.0.0.0
    • Local DNS : 0.0.0.0
  • Assign WAN Port to Switch : disabled
Wireless -> Basic settings
  • Wireless Physical Interface wl0
    • Wireless Mode : Repeater Bridge
    • Wireless Network Name (SSID) : <the exact SSID of your drone>
    • Network Configuration : Bridged
  • <add a virtual interface from the Add button below the Physical interface settings then>
  • Virtual Interfaces wl0.1 SSID
    • Wireless Network Name (SSID) : <a unique name in your environment, I used the name of the drone network + something>
    • Wireless SSID Broadcast : Enable
    • AP Isolation : Disable
    • Network Configuration : Bridged
Wireless -> Wireless security
  • Security Mode : Disabled on both wireless interfaces (physical and virtual)
Wireless -> Advanced settings
  • TX Power : the max allowed value, in my case it was default 71, max was 251, it should make a difference in range ...
  • Bluetooth Coexistence Mode : enable it if you will use something like the PS3 controller over bluetooth
Wireless -> MAC filter (optional but recommended, do this when everything else works)
  • Use Filter : Enable
  • Filter Mode : Permit only clients listed to access the wireless network
  • Edit MAC filter list : add here all MAC addresses of your devices (tablets, phones, laptops, whatever you use to access the router and/or the drone, you might need any of them later on ...)
This is just the official tutorial applied to the drone particular case, so please cross-check with the official instructions. Make sure you start from a clean configuration.

If it still doesn't work you can try to connect with a laptop to the router, with a fixed IP address like 192.168.1.3. Then open http://192.168.1.110 and see if that under Wireless -> Access point & Clients you see at least two MAC addresses:

Code: Select all

MAC Address	    Interface
<mac of drone >	eth1
<mac of laptop>	wl0.1
Then try to connect to the drone (ping 192.168.1.1 / telnet 192.168.1.1). If you get so far everything should be set up properly.

Good luck!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests